1

Filter setup in mileage sensor

(edited by mimicar 08/07/2015 11:34:47)

Topic: Filter setup in mileage sensor

Hello,
can anyone give me advice if there is any possibility to setup filter in mileage sensor setup to avoid increase of driven distance in reports? (See “Report” in picture)
It is caused by receiving of data from GPS unit in wrong order (see “Received messages from GPS Tracker” in picture).

Thank you.

2

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

mimicar, did you try to contact our Support first to check receiving part first (from device on server)?

At the dark side of telematics...
3

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

Yes, we contact Support and we tried to solve this problem. We solved only part of this problem by update of firmware from site of GPS unit manufacturer but in general this problem is still not completely solved sad

4

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

interesting, what HW are you using?

Wolf.

Politeness dictates it to write his name on a post
5

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

Hello Wolfgang, Teltonika with CAN BUS adapter  LV-CAN200.

6

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

Did you tried to use validation sensor referencing current and previous messages. It can control that mileage is always growing.

At the dark side of telematics...
7

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

Hello...no, we did not made any validation. Could you help us how to do it?

8

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

Create "mileage validator" sensor. Put into calculation table relative mileage between two messages. Trace new sensor value in messages mode and setup rule with calculation table to force null(zero) value in in problematic cases (probably it should be like 0 for all negative values and 1 for all other values)
Set ordinary mileage sensor validation with not-null check. And check it again messages mode.

At the dark side of telematics...
9

Filter setup in mileage sensor

(edited by mimicar 09/07/2015 14:43:54)

Re: Filter setup in mileage sensor

Hello Shal,
thank you for your manual, but somehow we were not able to make the setup :-(
Could you please write me more detailed procedure how to setup calculation table?
Possibly if it make no problem to you, export setup of sensors to WLP and we will import sensors directly to unit.
Thank you in advance.

10

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

What i dont understand at the moment:

Teltonika HW saves the data one by one in flash. if it lost connection it sends newest first and than older.
but as i understand Wialon saves them in order by valid GPS date and NOT by received time!
So as Wialon orders the raw data correct, the milleage must be also correct.

I think the main problem is: you send EVERY 2 SECONDS a new location. But the LV-CAN is polling data only very seldom from the canbus.
So i am sure that if you use something like "send every 30 seconds + every 15 deg" you will have much much better results!

Wolf

Politeness dictates it to write his name on a post
11

Filter setup in mileage sensor

Re: Filter setup in mileage sensor

wwbusch aka Buwo  you are right as usually. Super Wolf )

Labs Expert
Gurtam