1

problem with USB port in WL

Topic: problem with USB port in WL

Hello,

my WL is running on VESXI and now I need to connect the modem to send SMS.
I know this behaviour is not WL problem but googling I didn't find any valid solution to my problem.
basically I can't open the ttyUSB0 port and the kernel return this error

Sep 18 15:25:41 wialocal kernel: [1555092.679869] pl2303 2-2.1:1.0: pl2303_vendor_write - failed to write [0000]: -110
Sep 18 15:25:42 wialocal kernel: [1555093.680275] pl2303 ttyUSB0: pl2303_set_control_lines - failed: -110
Sep 18 15:25:49 wialocal kernel: [1555100.557497] pl2303 ttyUSB0: pl2303_set_control_lines - failed: -110
Sep 18 15:25:53 wialocal kernel: [1555104.567132] pl2303 ttyUSB0: error sending break = -110

does anybody encountered and fix the same problem?

thanks for any help
Ezio D.

2

problem with USB port in WL

Re: problem with USB port in WL

hi

(Interesting)

I have used a modem from wavecom with a USB cable type ,,,, and now, I've the same issue.

best regards

mohammed

Mohammed Abu Ghuffa
3

problem with USB port in WL

Re: problem with USB port in WL

Hi

I'm investigating this issue and one possibility is to change the usb-to-serial adapter from pl2303 to ftdi chipset. ordered the adapter, keep posted on result

ciao

4

problem with USB port in WL

Re: problem with USB port in WL

Hi,

I came up with some results.
first my wialon local is installed on vmware 6.7 and I've discovered that the passthrough option is not essential to be set to enable.
second, on the same VM I've installed a fresh new ubuntu and find that the pl2303 errors are still present here as well.
at the end I've disabled the passthrough on the VM, restarted the VM server, on the WL machine I've unload and realod the modules, like:
modprobe -r pl2303
modprobe -r usbserial
reboot WL
if necessary
modprobe pl2303

and now is 3 days that WL is correctly and communicating with the modem