1

Не могу залогиниться

Topic: Не могу залогиниться

Вот код программы в 1С

    Хост = "http://hosting.wialon.com/";
    Порт = 443;
    Логин = "wialon_test";
    Пароль = "test";
    Wialon = Новый COMОбъект("WialonActiveX.WialonConnection");
    Units = Wialon.Login(Хост, Порт, Логин, Пароль);
    Если Units = Неопределено Тогда
        Сообщить(Wialon.GetLastError());
        СообщитьОбОшибке("Ошибка подключения (Units=0)");
        ВызватьИсключение("");
    КонецЕсли;

Вот результат
WialonActiveX: Error login request
ОШИБКА: Ошибка подключения (Units=0)

2

Не могу залогиниться

Re: Не могу залогиниться

хост = activex.gurtam.com

Follow us on http://www.facebook.com/Gurtam
And take a look at new IoT backend by Gurtam.
3

Не могу залогиниться

Re: Не могу залогиниться

shal wrote:

хост = activex.gurtam.com

Исправил и добавил установку параметров прокси

Хост = "activex.gurtam.com";
    Порт = 443;
    Логин = "wialon_test";
    Пароль = "test";
    Wialon = Новый COMОбъект("WialonActiveX.WialonConnection");
    Wialon.SetProxyMode(ПроксиХост,ПроксиПорт,);
    Units = Wialon.Login(Хост, Порт, Логин, Пароль);
    Если Units = Неопределено Тогда
        Сообщить(Wialon.GetLastError());
        СообщитьОбОшибке("Ошибка подключения (Units=0)");
        ВызватьИсключение("");
    КонецЕсли;

Выдает следующую ошибку

WialonActiveX: Error create items

4

Не могу залогиниться

Re: Не могу залогиниться

Tinamu, ActiveX с некоторыми прокси не работает. Попробуйте без прокси.

5

Не могу залогиниться

Re: Не могу залогиниться

Если интерестно вот простой пример реализации
http://vdslabs.ru/node/12

Валерий Лобков
ООО "Спектр"
пгт. Тяжинский Кем. область
+79059024324
6

Не могу залогиниться

(edited by Wirth 13/08/2015 16:09:42)

Re: Не могу залогиниться

Та же ситуация:

WialonActiveX: Error create items

Прокси нет. Доступ на прямую.
Wialon local
ActiveX1.9.24x32

Подскажите, куда копать?

7

Не могу залогиниться

Re: Не могу залогиниться

Wirth, здравствуйте.
а можно уточнить номер вашего сервера?
можно даже в личку
или например на support@gurtam.com
проверим для начала комплектацию вашей лицензии

8

Не могу залогиниться

Re: Не могу залогиниться

Подскажите, где этот номер посмотреть?

9

Не могу залогиниться

(edited by shnaiderk 12/02/2016 06:01:08)

Re: Не могу залогиниться

Та же самая ошибка:
Wialon Hosting

Сервер = "activex.gurtam.com";
Порт = 443;
Логин = "...тут наш логин..."; //Админский
Пароль = "…тут наш пароль….";
Wialon = Новый COMОбъект("WialonActiveX.WialonConnection");
Попытка
               Units = Wialon.Login(Сервер,Порт, Логин, Пароль);
Исключение
               ТекстОшибки = Wialon.GetLastError();
               Сообщить(ТекстОшибки);                        
КонецПопытки;              
Если Units = Неопределено Тогда
               ТекстОшибки = Wialon.GetLastError();
               Сообщить(ТекстОшибки);
КонецЕсли;

WialonActiveX: Error create items

Пробовали через пример в файле Excel WialonActiveXExample.xls.
Результат тот же.
Коллеги, подскажите в чем проблема? Куда "рыть"?

10

Не могу залогиниться

Re: Не могу залогиниться

Я не спецулист по ActiveX, но... кажется этот способ аутентификации отключен с октября 2015. Во всяком случае на Ява теперь все через токен делается, а попытка залогиниться через усер/пароль выдает ошибку.

11

Не могу залогиниться

Re: Не могу залогиниться

Разобрались сами в чем проблема.
Была отключена опция ActiveX у аккаунта.
Включили опцию и все заработало.

12

Не могу залогиниться

Re: Не могу залогиниться

shnaiderk wrote:

Разобрались сами в чем проблема.
Была отключена опция ActiveX у аккаунта.
Включили опцию и все заработало.

Подскажите пожалуйста, где эта опция включается. Я не администратор сервера мониторинга, а программист 1с, интегрируюсь с виалон через ActiveX.

13

Не могу залогиниться

Re: Не могу залогиниться

vikvikmag, судя по всему под опцией ActiveX shnaiderk имеет ввиду услугу (сервис) ActiveX в учётке.

Solutions Department
Gurtam